AndroidProjectCreator 1.5.1-stable release

This AndroidProjectCreator update brings a simple yet required change: the the org.eclipse.jgit dependency uses Log4J, which has a severe remote code execution vulnerability in it, tracked as CVE-2021-44228. To avoid needless error messages, AndroidProjectCreator embeds the logger. The Log4J version that is used, has been updated to a version that is not vulnerable anymore, which should remediate the issue.

The program’s source code can be found here, along with the latest release. Updating is as easy as replacing the JAR by the latest release, or by building the latest source and using your self-built JAR as the replacement.

Feedback and suggestions can be shared via any of the contact methods that are listed below, or by creating an issue on GitHub. When picking the latter, please do use the given issue template.


To contact me, you can e-mail me at [info][at][maxkersten][dot][nl], send me a PM on Reddit, or DM me on Twitter @Libranalysis.